Coding 2021-09-06

By Max Woerner Chase

Doing time. Wait, no... Eh.

Anyway, I started adding the basic types that I determined I'll need. Then I added a utility function that I'll definitely want to put into the MOTR app sooner than later. But that utility function raised a question for me that I want to look into sooner than later:

Since I'm using attr's dataclasses to define all of my Action implementations, is it worth coming up with a separate name like I am currently? When it comes to reporting them, can I get by with some form of pretty-printing?

Looking into the first question...

Popping open motr.core.registry...

The main things that would need to change are the Action class in there would stop existing, as well as the ActionName class. This changes the following attributes and methods on Registry:

I think the thing to do is just to try it, because I'm not seeing all of the consequences, and I've got source control.

log_dir = self.target.log_dir / self.action_name

Ah. Right.

I'm going to need to think about the best way to deal with that. I'll just leave this as-is for tonight, and see if I come up with anything in the next week. (I mean, I suppose if I'm lazy, I could use the id and just include that in the output, but that's really lazy...)

Anyway, I'm going to wind down now.

Good night.