Coding 2022-08-01

By Max Woerner Chase

I wrote up the helper methods for MOTR, and after some slight implementation issues, I got them added to one of the tests.

Then, I got back into documenting stuff. I think it's time for me to start reconsidering the names of some of this stuff, because some of this code is hard to document when the names clearly have nothing to do with the purpose.

So, that's going to be the next stretch of work I do with this code: collect all of my misgivings about class and function names into a single place so I can prioritize them. I may also take notes on some functionality changes I want: stuff like removing isinstance() calls and streamlining the command wrappers.

Anyway, I'm exhausted for some reason, so I guess I'm getting to bed now.

Good night.